MPLAB 6 Support

CC5X
CC8E
Home Page

MPLAB Support

CC5X and CC8E can be used in the MPLAB environment. Compilation, POINT-AND-CLICK on error messages is supported. Both single module and multi module projects is possible.

IMPORTANT: The newer MPLAB X is not supported, which means that MPLAB 8.91 is the latest version supported.

MPLAB version 6.61 - 8.91: will load the generated COD file automatically. It is required to carefully follow the steps described in INSTALL.TXT. Also visit the FAQ page.

For best information and integration, CC5X version 3.1I or later and CC8E version 1.0H or later should be used. Older compiler versions requires that option -FM is not used (option -F can be used instead).


Older MPLAB versions

MPLAB version 6.50 - 6.60 : same as version 6.30 - 6.42, except that MPLAB will not load the generated COD file automatically. A workaround is found on the FAQ page (for both CC5X and CC8E).

MPLAB version 6.30 - 6.42 : supports the MTC integration similar to MPLAB 5. The description is found in INSTALL.TXT in the compiler package.

MPLAB version 6.00 - 6.20 : not supported.

MPLAB version 5.xx : description is found in file INSTALL.TXT

 

End line